Home Forums Bunifu UI Winforms This software was developed using a trial version of Bunifu Framework

Tagged: 

Viewing 0 reply threads
  • Author
    Posts
    • Dennis
      Participant
      Post count: 2

      I’m just about to give up on this framework…
      I tried your support first, but after an hour all they managed to do was to tell me my license is okay, so I’m giving this one last chance in the forums.

      No matter what I do, I always get a splash screen saying my software was created using a trial version of Bunifu Framework.

      So far I tried:

      1. Creating a new project, adding the 5.0.3 NuGet. Upon adding the controls to the project I get a screen asking me fr the credentials (email and license key), I supply it and it says it’s all good. I then tried cleaning, rebuilding and god knows what, as soon as I run the application it says it’s a trial version.

      2. I tried deleting the files in ‘C:\ProgramData\Bunifu Technologies\UIWinForms’, redoing the activation, no change.

      3. Deleting the keys in the registry. No change. (together with deleting the files on the drive of course and all possible combinations).

      4. Deleting all Bunifu related files o the hard drive, re-adding them, testing it again. No change.

      5. Reinstalling windows and Visual Studio (2019 and also 2015) on a virtual machine. No change, same problem.

      6. Tested all NuGet versions all the way back to 4.0.0. No change, always a splash screen.

      After playing around deleting files and registry keys I’ve ended up with a few test projects not being able to run at all with an exception saying:

      “An unhandled exception of type ‘System.ComponentModel.LicenseException’ occurred in Bunifu.Licensing.dll
      Additional information: This product does not have a valid Bunifu UI WinForms license to run.”

      That one is a bit odd because 2 projects in the same solution get the splash screen and another one gets that exception.

Viewing 0 reply threads
  • You must be logged in to reply to this topic.